[jira] [Resolved] (DELTASPIKE-1344) deltaspike-cdictrl-owb has a transient runtime dependency on Shrinkwrap and Arquillian

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Resolved] (DELTASPIKE-1344) deltaspike-cdictrl-owb has a transient runtime dependency on Shrinkwrap and Arquillian

JIRA jira@apache.org

     [ https://issues.apache.org/jira/browse/DELTASPIKE-1344?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Mark Struberg resolved DELTASPIKE-1344.
---------------------------------------
       Resolution: Fixed
    Fix Version/s: 1.9.0
                   1.8.2

> deltaspike-cdictrl-owb has a transient runtime dependency on Shrinkwrap and Arquillian
> --------------------------------------------------------------------------------------
>
>                 Key: DELTASPIKE-1344
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-1344
>             Project: DeltaSpike
>          Issue Type: Bug
>          Components: CdiControl
>    Affects Versions: 1.8.1
>            Reporter: Robert Panzer
>            Assignee: Mark Struberg
>            Priority: Minor
>             Fix For: 1.8.2, 1.9.0
>
>
> deltaspike-cdictrl-impl-owb contains a compile dependency on deltaspike test-utils, which in turn has dependencies on pretty old versions of Shrinkwrap, Arquillian and maven-artifact:
> [https://github.com/apache/deltaspike/blob/3ed354b373c574442d0e75c4b576010bce42efb8/deltaspike/cdictrl/impl-owb/pom.xml#L41-L45]
> Is this necessary?
> It can be annoying to find out why dependencies are suddenly wrong if you're not aware of it. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)