[DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

[DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

Mark Struberg-3
Hi folks!

Our build, etc in theory still runs with Java6.
As typical with ASF projects we make battle prooven projects for production.
That means we take backward compatibility really serious.

But I think it's finally time to up the game to Java8.
To indicate this I suggest to move from currently 1.8.x to 1.9.x.

Note that all the rest will still be backward compatible with older versions!
We also might still ship 1.8.2, 1.8.3, etc as Java7 compatible version if there is any necessity.

Any objections?

LieGrue,
strub
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

Romain Manni-Bucau
+1, even big data libs like apache beam are java 8 based now so if big data
moved to j8, server techno should have moved already IMHO ;)

Le 1 mars 2018 05:48, "Mark Struberg" <[hidden email]> a écrit :

> Hi folks!
>
> Our build, etc in theory still runs with Java6.
> As typical with ASF projects we make battle prooven projects for
> production.
> That means we take backward compatibility really serious.
>
> But I think it's finally time to up the game to Java8.
> To indicate this I suggest to move from currently 1.8.x to 1.9.x.
>
> Note that all the rest will still be backward compatible with older
> versions!
> We also might still ship 1.8.2, 1.8.3, etc as Java7 compatible version if
> there is any necessity.
>
> Any objections?
>
> LieGrue,
> strub
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

Christian Kaltepoth
+1, we will get Java10 really soon, so requiring at least Java8 seems
reasonable.

2018-03-01 7:11 GMT+01:00 Romain Manni-Bucau <[hidden email]>:

> +1, even big data libs like apache beam are java 8 based now so if big data
> moved to j8, server techno should have moved already IMHO ;)
>
> Le 1 mars 2018 05:48, "Mark Struberg" <[hidden email]> a écrit
> :
>
> > Hi folks!
> >
> > Our build, etc in theory still runs with Java6.
> > As typical with ASF projects we make battle prooven projects for
> > production.
> > That means we take backward compatibility really serious.
> >
> > But I think it's finally time to up the game to Java8.
> > To indicate this I suggest to move from currently 1.8.x to 1.9.x.
> >
> > Note that all the rest will still be backward compatible with older
> > versions!
> > We also might still ship 1.8.2, 1.8.3, etc as Java7 compatible version if
> > there is any necessity.
> >
> > Any objections?
> >
> > LieGrue,
> > strub
>



--
Christian Kaltepoth
Blog: http://blog.kaltepoth.de/
Twitter: http://twitter.com/chkal
GitHub: https://github.com/chkal
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

Cody Lerum
In reply to this post by Mark Struberg-3
+1 there is no reason for someone running Java 7 to expect new features
from Deltaspike.

On Feb 28, 2018 9:48 PM, "Mark Struberg" <[hidden email]> wrote:

> Hi folks!
>
> Our build, etc in theory still runs with Java6.
> As typical with ASF projects we make battle prooven projects for
> production.
> That means we take backward compatibility really serious.
>
> But I think it's finally time to up the game to Java8.
> To indicate this I suggest to move from currently 1.8.x to 1.9.x.
>
> Note that all the rest will still be backward compatible with older
> versions!
> We also might still ship 1.8.2, 1.8.3, etc as Java7 compatible version if
> there is any necessity.
>
> Any objections?
>
> LieGrue,
> strub
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

John D. Ament
IMHO to move to Java 8 we need to drop support for EE6/EE7.  So to me that
says the next version is 2.0 not 1.9.x.

There are some weld 1.1 versions that support this, but no testable AS7
instance that we can check against.

John

On Thu, Mar 1, 2018 at 9:35 AM Cody Lerum <[hidden email]> wrote:

> +1 there is no reason for someone running Java 7 to expect new features
> from Deltaspike.
>
> On Feb 28, 2018 9:48 PM, "Mark Struberg" <[hidden email]>
> wrote:
>
> > Hi folks!
> >
> > Our build, etc in theory still runs with Java6.
> > As typical with ASF projects we make battle prooven projects for
> > production.
> > That means we take backward compatibility really serious.
> >
> > But I think it's finally time to up the game to Java8.
> > To indicate this I suggest to move from currently 1.8.x to 1.9.x.
> >
> > Note that all the rest will still be backward compatible with older
> > versions!
> > We also might still ship 1.8.2, 1.8.3, etc as Java7 compatible version if
> > there is any necessity.
> >
> > Any objections?
> >
> > LieGrue,
> > strub
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

Romain Manni-Bucau
2018-03-01 15:50 GMT+01:00 John D. Ament <[hidden email]>:

> IMHO to move to Java 8 we need to drop support for EE6/EE7.  So to me that
> says the next version is 2.0 not 1.9.x.
>

It is way too early for cdi 2, almost no users rely on that yet compared to
cdi 1.x.


>
> There are some weld 1.1 versions that support this, but no testable AS7
> instance that we can check against.
>

Isnt wildfly enough now? Maybe JBoss guys can help us here as well.


>
> John
>
> On Thu, Mar 1, 2018 at 9:35 AM Cody Lerum <[hidden email]> wrote:
>
> > +1 there is no reason for someone running Java 7 to expect new features
> > from Deltaspike.
> >
> > On Feb 28, 2018 9:48 PM, "Mark Struberg" <[hidden email]>
> > wrote:
> >
> > > Hi folks!
> > >
> > > Our build, etc in theory still runs with Java6.
> > > As typical with ASF projects we make battle prooven projects for
> > > production.
> > > That means we take backward compatibility really serious.
> > >
> > > But I think it's finally time to up the game to Java8.
> > > To indicate this I suggest to move from currently 1.8.x to 1.9.x.
> > >
> > > Note that all the rest will still be backward compatible with older
> > > versions!
> > > We also might still ship 1.8.2, 1.8.3, etc as Java7 compatible version
> if
> > > there is any necessity.
> > >
> > > Any objections?
> > >
> > > LieGrue,
> > > strub
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

Rudy De Busscher
In reply to this post by John D. Ament
Maybe not drop EE7. I think all current app servers supporting Java EE 7
runs on Java 8.

But removing EE6, means for example that we no longer need BeanProvider and
other specific code for EE6.

So changing to Java 8 has quite some impact (but Java 8 is wanted I guess)
and thus requires 2.x numbering.

Rudy

On 1 March 2018 at 15:50, John D. Ament <[hidden email]> wrote:

> IMHO to move to Java 8 we need to drop support for EE6/EE7.  So to me that
> says the next version is 2.0 not 1.9.x.
>
> There are some weld 1.1 versions that support this, but no testable AS7
> instance that we can check against.
>
> John
>
> On Thu, Mar 1, 2018 at 9:35 AM Cody Lerum <[hidden email]> wrote:
>
> > +1 there is no reason for someone running Java 7 to expect new features
> > from Deltaspike.
> >
> > On Feb 28, 2018 9:48 PM, "Mark Struberg" <[hidden email]>
> > wrote:
> >
> > > Hi folks!
> > >
> > > Our build, etc in theory still runs with Java6.
> > > As typical with ASF projects we make battle prooven projects for
> > > production.
> > > That means we take backward compatibility really serious.
> > >
> > > But I think it's finally time to up the game to Java8.
> > > To indicate this I suggest to move from currently 1.8.x to 1.9.x.
> > >
> > > Note that all the rest will still be backward compatible with older
> > > versions!
> > > We also might still ship 1.8.2, 1.8.3, etc as Java7 compatible version
> if
> > > there is any necessity.
> > >
> > > Any objections?
> > >
> > > LieGrue,
> > > strub
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

Thomas Andraschko-2
In reply to this post by Romain Manni-Bucau
IMO
DS1.x = JavaEE 7
DS2.x = JavaEE 8

Java8 in 1.x is fine for me, we can try to improve our APIs with Java8
In 2.x we can even improve further and cleanup then


2018-03-01 15:55 GMT+01:00 Romain Manni-Bucau <[hidden email]>:

> 2018-03-01 15:50 GMT+01:00 John D. Ament <[hidden email]>:
>
> > IMHO to move to Java 8 we need to drop support for EE6/EE7.  So to me
> that
> > says the next version is 2.0 not 1.9.x.
> >
>
> It is way too early for cdi 2, almost no users rely on that yet compared to
> cdi 1.x.
>
>
> >
> > There are some weld 1.1 versions that support this, but no testable AS7
> > instance that we can check against.
> >
>
> Isnt wildfly enough now? Maybe JBoss guys can help us here as well.
>
>
> >
> > John
> >
> > On Thu, Mar 1, 2018 at 9:35 AM Cody Lerum <[hidden email]> wrote:
> >
> > > +1 there is no reason for someone running Java 7 to expect new features
> > > from Deltaspike.
> > >
> > > On Feb 28, 2018 9:48 PM, "Mark Struberg" <[hidden email]>
> > > wrote:
> > >
> > > > Hi folks!
> > > >
> > > > Our build, etc in theory still runs with Java6.
> > > > As typical with ASF projects we make battle prooven projects for
> > > > production.
> > > > That means we take backward compatibility really serious.
> > > >
> > > > But I think it's finally time to up the game to Java8.
> > > > To indicate this I suggest to move from currently 1.8.x to 1.9.x.
> > > >
> > > > Note that all the rest will still be backward compatible with older
> > > > versions!
> > > > We also might still ship 1.8.2, 1.8.3, etc as Java7 compatible
> version
> > if
> > > > there is any necessity.
> > > >
> > > > Any objections?
> > > >
> > > > LieGrue,
> > > > strub
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

John D. Ament
I think assuming all EE7 vendors support Java 8 then I think its fine.  But
I definitely believe we can't do EE6 on Java 8.

John

On Thu, Mar 1, 2018 at 10:06 AM Thomas Andraschko <
[hidden email]> wrote:

> IMO
> DS1.x = JavaEE 7
> DS2.x = JavaEE 8
>
> Java8 in 1.x is fine for me, we can try to improve our APIs with Java8
> In 2.x we can even improve further and cleanup then
>
>
> 2018-03-01 15:55 GMT+01:00 Romain Manni-Bucau <[hidden email]>:
>
> > 2018-03-01 15:50 GMT+01:00 John D. Ament <[hidden email]>:
> >
> > > IMHO to move to Java 8 we need to drop support for EE6/EE7.  So to me
> > that
> > > says the next version is 2.0 not 1.9.x.
> > >
> >
> > It is way too early for cdi 2, almost no users rely on that yet compared
> to
> > cdi 1.x.
> >
> >
> > >
> > > There are some weld 1.1 versions that support this, but no testable AS7
> > > instance that we can check against.
> > >
> >
> > Isnt wildfly enough now? Maybe JBoss guys can help us here as well.
> >
> >
> > >
> > > John
> > >
> > > On Thu, Mar 1, 2018 at 9:35 AM Cody Lerum <[hidden email]>
> wrote:
> > >
> > > > +1 there is no reason for someone running Java 7 to expect new
> features
> > > > from Deltaspike.
> > > >
> > > > On Feb 28, 2018 9:48 PM, "Mark Struberg" <[hidden email]>
> > > > wrote:
> > > >
> > > > > Hi folks!
> > > > >
> > > > > Our build, etc in theory still runs with Java6.
> > > > > As typical with ASF projects we make battle prooven projects for
> > > > > production.
> > > > > That means we take backward compatibility really serious.
> > > > >
> > > > > But I think it's finally time to up the game to Java8.
> > > > > To indicate this I suggest to move from currently 1.8.x to 1.9.x.
> > > > >
> > > > > Note that all the rest will still be backward compatible with older
> > > > > versions!
> > > > > We also might still ship 1.8.2, 1.8.3, etc as Java7 compatible
> > version
> > > if
> > > > > there is any necessity.
> > > > >
> > > > > Any objections?
> > > > >
> > > > > LieGrue,
> > > > > strub
> > > >
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

Rudy De Busscher
In reply to this post by Thomas Andraschko-2
Strictly speaking, DS1.x is Java EE 6 based (because we are using CDI 1.0,
JSF 2.0)

But probably no harm in just setting compiler to java 8. (and indicate that
DS 1.9 only run on Java EE 7 server with Java 8)

On 1 March 2018 at 16:05, Thomas Andraschko <[hidden email]>
wrote:

> IMO
> DS1.x = JavaEE 7
> DS2.x = JavaEE 8
>
> Java8 in 1.x is fine for me, we can try to improve our APIs with Java8
> In 2.x we can even improve further and cleanup then
>
>
> 2018-03-01 15:55 GMT+01:00 Romain Manni-Bucau <[hidden email]>:
>
> > 2018-03-01 15:50 GMT+01:00 John D. Ament <[hidden email]>:
> >
> > > IMHO to move to Java 8 we need to drop support for EE6/EE7.  So to me
> > that
> > > says the next version is 2.0 not 1.9.x.
> > >
> >
> > It is way too early for cdi 2, almost no users rely on that yet compared
> to
> > cdi 1.x.
> >
> >
> > >
> > > There are some weld 1.1 versions that support this, but no testable AS7
> > > instance that we can check against.
> > >
> >
> > Isnt wildfly enough now? Maybe JBoss guys can help us here as well.
> >
> >
> > >
> > > John
> > >
> > > On Thu, Mar 1, 2018 at 9:35 AM Cody Lerum <[hidden email]>
> wrote:
> > >
> > > > +1 there is no reason for someone running Java 7 to expect new
> features
> > > > from Deltaspike.
> > > >
> > > > On Feb 28, 2018 9:48 PM, "Mark Struberg" <[hidden email]>
> > > > wrote:
> > > >
> > > > > Hi folks!
> > > > >
> > > > > Our build, etc in theory still runs with Java6.
> > > > > As typical with ASF projects we make battle prooven projects for
> > > > > production.
> > > > > That means we take backward compatibility really serious.
> > > > >
> > > > > But I think it's finally time to up the game to Java8.
> > > > > To indicate this I suggest to move from currently 1.8.x to 1.9.x.
> > > > >
> > > > > Note that all the rest will still be backward compatible with older
> > > > > versions!
> > > > > We also might still ship 1.8.2, 1.8.3, etc as Java7 compatible
> > version
> > > if
> > > > > there is any necessity.
> > > > >
> > > > > Any objections?
> > > > >
> > > > > LieGrue,
> > > > > strub
> > > >
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

Mark Struberg-3
In reply to this post by John D. Ament
JBoss 6 EAP is Java8 on EE6 - still often used in production
WebSphere 8.5.x is Java8 on EE6  - still often used in production
WebLogic is mess on it's own afaict. There are WLS12 which target EE6 and some which are target EE7. Not having them at any of my customers though
TomEE-1.7.5 runs fine on Java8. TomEE users are mostly on TomEE7 already, so that's not a blocker probably.

Point is that we don't gain much from requiring EE7. We gain quite a bit from Java8 though.

LieGrue,
strub


> Am 01.03.2018 um 16:14 schrieb John D. Ament <[hidden email]>:
>
> I think assuming all EE7 vendors support Java 8 then I think its fine.  But
> I definitely believe we can't do EE6 on Java 8.
>
> John
>
> On Thu, Mar 1, 2018 at 10:06 AM Thomas Andraschko <
> [hidden email]> wrote:
>
>> IMO
>> DS1.x = JavaEE 7
>> DS2.x = JavaEE 8
>>
>> Java8 in 1.x is fine for me, we can try to improve our APIs with Java8
>> In 2.x we can even improve further and cleanup then
>>
>>
>> 2018-03-01 15:55 GMT+01:00 Romain Manni-Bucau <[hidden email]>:
>>
>>> 2018-03-01 15:50 GMT+01:00 John D. Ament <[hidden email]>:
>>>
>>>> IMHO to move to Java 8 we need to drop support for EE6/EE7.  So to me
>>> that
>>>> says the next version is 2.0 not 1.9.x.
>>>>
>>>
>>> It is way too early for cdi 2, almost no users rely on that yet compared
>> to
>>> cdi 1.x.
>>>
>>>
>>>>
>>>> There are some weld 1.1 versions that support this, but no testable AS7
>>>> instance that we can check against.
>>>>
>>>
>>> Isnt wildfly enough now? Maybe JBoss guys can help us here as well.
>>>
>>>
>>>>
>>>> John
>>>>
>>>> On Thu, Mar 1, 2018 at 9:35 AM Cody Lerum <[hidden email]>
>> wrote:
>>>>
>>>>> +1 there is no reason for someone running Java 7 to expect new
>> features
>>>>> from Deltaspike.
>>>>>
>>>>> On Feb 28, 2018 9:48 PM, "Mark Struberg" <[hidden email]>
>>>>> wrote:
>>>>>
>>>>>> Hi folks!
>>>>>>
>>>>>> Our build, etc in theory still runs with Java6.
>>>>>> As typical with ASF projects we make battle prooven projects for
>>>>>> production.
>>>>>> That means we take backward compatibility really serious.
>>>>>>
>>>>>> But I think it's finally time to up the game to Java8.
>>>>>> To indicate this I suggest to move from currently 1.8.x to 1.9.x.
>>>>>>
>>>>>> Note that all the rest will still be backward compatible with older
>>>>>> versions!
>>>>>> We also might still ship 1.8.2, 1.8.3, etc as Java7 compatible
>>> version
>>>> if
>>>>>> there is any necessity.
>>>>>>
>>>>>> Any objections?
>>>>>>
>>>>>> LieGrue,
>>>>>> strub
>>>>>
>>>>
>>>
>>